dpkg: error processing package libglib2.0-0:i386 (--configure) on APT dist upgrade

Written by - 0 comments

Published on - Listed in Linux


After running apt-get dist-upgrade on my Linux Mint (currently version 20.2 Uma), I was surprised to see a lot of dependency errors related to a 32 bit package:

root@mintp:~# apt-get update
[...]
Preparing to unpack .../libgail-3-0_3.24.20-0ubuntu1.1_amd64.deb ...
Unpacking libgail-3-0:amd64 (3.24.20-0ubuntu1.1) over (3.24.20-0ubuntu1) ...
Preparing to unpack .../libgtk-3-0_3.24.20-0ubuntu1.1_amd64.deb ...
Unpacking libgtk-3-0:amd64 (3.24.20-0ubuntu1.1) over (3.24.20-0ubuntu1) ...
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libc6 (>= 2.28); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libc6 (>= 2.28); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libc6 (>= 2.28); however:
  Package libc6:i386 is not configured yet.
[...]
dpkg: too many errors, stopping
Errors were encountered while processing:
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Luckily this can be fixed using the following commands:

root@mintp:~# dpkg --configure -a
Setting up firefox (98.0.2+linuxmint1+una) ...
[...]
Processing triggers for libc-bin (2.31-0ubuntu9.7) ...
Processing triggers for systemd (245.4-4ubuntu3.15) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for ureadahead (0.100.0-21) ...
Processing triggers for mintsystem (8.5.2) ...
Processing triggers for desktop-file-utils (0.24+linuxmint1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libglib2.0-0:amd64 (2.64.6-1~ubuntu20.04.4) ...
Processing triggers for libglib2.0-0:i386 (2.64.6-1~ubuntu20.04.4) ...

Setting up libgtk-3-0:amd64 (3.24.20-0ubuntu1.1) ...
Setting up libgail-3-0:amd64 (3.24.20-0ubuntu1.1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.7) ...

and:

root@mintp:~# apt --fix-broken install

After these two commands, apt-get upgrade ran through just fine.


Add a comment

Show form to leave a comment

Comments (newest first)

No comments yet.

Blog Tags: